RSS

Tag Archives: FRM-92101: There was a failure in form server during startup

R12 after clone Error -FRM-92101 – on OEL5.7

after cloning R12 instance on OEL 5.7 64bit to TEST instance and when I started services normally, an error apprears when access the forms, getting the following error

FRM-92101: There was a failure in the Forms Server during startup. This could happen due to invalid configuration. Please look into the web-server log file for details

 
Java Exception
oracle.forms.net.ConnectionException:Forms sessionfailed during startup:no response from runtime process
at oracle.forms.net.ConnectionException.createConnectionException(Unknown Source)
at oracle.forms.net.HTTPNStream.getResponse(Unknown source)
at oracle.forms.net.HTTPNStream.doFlush(Unknown Source)
at oracle.forms.net.HTTPNStream.flush(Unknown Source)
at java.io.DataOutputStream.flush(Unknown source)
…………………………………………………………..

I have looked into the forms server log file which is given below

$LOG_HOME/ora/10.1.3/opmn/forms_default_group_1/formsstd.out

and found the following error

FormsServlet init():
configFileName: /u01/DEV/inst/apps/DEV_mkhots06/ora/10.1.2/forms/server/appsweb.cfg
testMode: false
Oracle Containers for J2EE 10g (10.1.3.4.0) initialized
ListenerServlet init()
Forms session <1> aborted: runtime process failed during startup with errors <ORACLE_HOME>/bin/frmweb: error while loading shared libraries: libXm.so.2: cannot open shared object file: No such file or directory

Forms session <2> aborted: runtime process failed during startup with errors <ORACLE_HOME>/bin/frmweb: error while loading shared libraries: libXm.so.2: cannot open shared object file: No such file or directory

Forms session <3> aborted: runtime process failed during startup with errors <ORACLE_HOME>/bin/frmweb: error while loading shared libraries: libXm.so.2: cannot open shared object file: No such file or directory

Cause:

The Actual cause of this error for my test instance is that openmotif package not installed along with pre-requisites for R12 in TEST instance server.

rpm -Uhv binutils-2.17.50.0.6-6.0.1.el5.x86_64.rpm
rpm -Uhv xorg-x11-libs-compat-6.8.2-1.EL.33.0.1.i386.rpm
rpm -Uhv openmotif21-2.1.30-11.EL5.i386.rpm

then after that i hav relinked the frmweb executable of forms server after shutting the apps services by giving the following commands

$cd $ADMIN_SCRIPTS_HOME

$adstpall.sh apps/

Then

$cd $ORACLE_HOME/forms/lib

$make -f ins_forms.mk install

Then restarted the services using adstrtal.sh apps/

Now there is no issue of form errors and was able to access the forms from my TEST instance.

 

Tags: , ,